Resultados 1 al 1 de 1

Tema: Uso de Netwatch con variables

  1. #1
    Recluta Avatar de DaLiCaM
    Fecha de ingreso
    06 feb, 18
    Mensajes
    1

    Uso de Netwatch con variables

    Hola Comunidad

    Este es mi primer post por aquí. mi duda es la siguiente, es posible capturar una variable de hora y usarla en otro momento?
    Me explico, tengo en netwatch un script que verifica cuando hay caída de internet, suponiendo que no hay conectividad hacia internet a las 10:25 am, capturar esa hora en una variable y usarla para enviar un reporte del incidente cuando se restablezca la conectividad, digo esto ya que actualmente no tengo una conexión de respaldo.

    Actualmente tengo el script Netwatch de la siguiente forma:

    Up:
    Código:
    :local fechaup [/system clock get date]
    :local horaup [/system clock get time]
    :log info "Internet está en linea a las $horaup horas fecha $fechaup"
    :tool e-mail send to=correo1@dominio.com cc=corre2@dominio.com  body="Se ha restablecido la conectividad a internet, a las $hora del día $fechaup, pero hubo una caida a las $horadown del día $fechadown" subject="Mensaje Automático de restablecimiento del Servicio de Internet Mikrotik"
    :log info "Ha sido enviado un email de restablecimiento de Servicio de Internet por correo electronico el dia $fechaup a las $horaup"
    Down:
    Código:
    :local fechadown [/system clock get date]
    :local horadown [/system clock get time]
    ::log info "Se ha perdido conectividad de internet el dia $fechadown a las $horadown"
    Saludos.
    Última edición por DaLiCaM; 06/02/2018 a las 11:17

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •